Логин:
Пароль:

http://lfforever.ru/design/ds_dw.css http://lfforever.ru/design/black.css
Сменить скин
[ Новые сообщения · Участники · Правила форума · Поиск · RSS ]
Страница 6 из 10«1245678910»
Фан Форум для LF'айтеров » Игровые Серверы » Minecraft » Сервак MC для LFF :3
Сервак MC для LFF :3
11.06.13 17:43 | #101

Репутация: 459
Постов: 3336
А далее...

11.06.13 17:57 | #102

Репутация: 10
Постов: 345
интрегующий расказ но вот вщом вопрос кто станит богом маинкрафта а кто останится нищем О_о........
11.06.13 18:41 | #103

Репутация: 459
Постов: 3336
Предлагаю мод на биомы для нового мира.
Переходите по ссылке и смотрите скрины под спойлерами.
Ссылка!
Мод ExtraBiomesXL добавляет в майнкрафт много реалистичных биом (тайга, красный лес, болота, зелёные луга и прочие), всего 23 биомы, но зато каких!

Кто за, поддержите предложение :)

11.06.13 18:58 | #104

Репутация: 439
Постов: 1220
Шад,я за)
11.06.13 20:23 | #105

Репутация: 408
Постов: 8023
Хорошо, добавлю
11.06.13 21:22 | #106

Репутация: 459
Постов: 3336
Предвкушаю, как будет здорово.
Буду исследовать мир с теми же ощущениями, как в первые дни знакомства с майном)
Вроде бы там новые строение могут генерироваться

11.06.13 22:52 | #107

Репутация: 408
Постов: 8023
Довольно важный нюанс сообщу:
будет произведен даунгрейд с 1.5.2 на 1.5.1
пока делал сборку, обнаружил ряд серьезных проблем, связанных с последним апдейтом, но так как по логам разработчика там ничего сверхважного не появлялось и не фиксилось, разницы практически никакой не будет для игроков.
Более детальную тех. информацию я сообщу после обновления.

11.06.13 23:07 | #108

Репутация: 130
Постов: 1103
Цитата (EdL)
будет произведен даунгрейд с 1.5.2 на 1.5.1

=(

11.06.13 23:09 | #109

Репутация: 408
Постов: 8023
Цитата
=(

какие причины для грусти-то?)

11.06.13 23:14 | #110

Репутация: 130
Постов: 1103
Клиент 1.5.2. при подключении к серверам низшей версии пишет "Outdate server!"
11.06.13 23:42 | #111

Репутация: 408
Постов: 8023
да, это одно из скрытых изменений от разрабов, об этом пишут только мододелы, но не авторы обновления...
Но сейчас в мире актуальны 3 версии: 1.4.7 , 1.5.1 и 1.5.2, где последнюю разработчики дополнений яростно игнорируют.
В майне есть нумерация протокола и ключи обработки (назовем это так), и из версии 1.5.1 до 1.5.2 обе эти вещи изменились, отчего (не смотря на то, что это 1.5.х) версии стали несовместимы. Некоторые мододелы сознательно не делают ничего на 1.5.2, так как от этого, пока что, только головная боль. Возможно дела изменятся к выходу 1.6, но авторы движков серверов сами не торопятся их обновлять, всех устраивает 1.5.1.
По своим наблюдениям заметил, что где-то 1\4 всех модов на всей тройке топ 3 версий, то есть они не используют ничего важного от игры, чтобы работать.
В сети распространяются фанатские обновления старых модов. Например из 1.5.1 до 1.5.2. Но если клиенты ещё могут проигнорировать ошибки, допущенные таким фан-апдейтом, то сервак и вовсе крашится, хотя версия и сервера, и клиента одна и та же. Так же бывает и у авторов самих модов, они делают обновление с 1.5.1 на 1.5.2, но оно работает только на локальном уровне, а серваки падают.

я не говорю, что переход будет 100%, но если по ходу разработки и поднятия серва конфликтов и ошибок будет меньше, чем в 1.5.2, то выбор очевиден в пользу стабильности.

12.06.13 00:34 | #112

Репутация: 408
Постов: 8023
Для игроков разницы не будет практически, я уже нашел тот набор биомов для 1.5.1 и все моды, которые до этого отобрал на 1.5.2
12.06.13 01:31 | #113

Репутация: 122
Постов: 851
EdL, Ric Warrior, найти старые версии много чего легче, чем новые....многое хорошее давно забросилось (частично изза обновлений, т.к. какие-то подобные ввелись). плохо, что не все дальше портируют...
12.06.13 10:43 | #114

Репутация: 130
Постов: 1103
Обновления на майнкрафт выходят очень часто. Иногда по 2-3 в месяц, иногда 1 раз в месяц. Последнее обновление было 2 мая, следущее выйдет в этом месяце.
Версии всегда были несовместимы друг с другом, исключения составляют 1.4.7 (совместима с 1.4.6) и 1.4.5 (совместима с 1.4.4). Наверно поэтому есть те кто юзает 1.4.7.
Кстати, версия 1.4.7 популярна еще тем, что это последняя версия, содержащая Хиробина. Это своеобразный мем Майнкрафта - человечек призрак.
Вобщем с 1.4.7 произошло очень много изменений. А вот переход на 1.5.2. содержит лишь исправления багов. История версий.
Так что, если работоспособность модов на сервере будет зависеть от отката на 1.5.1 то пожалуйста. Хотя это будет геморр для меня.

12.06.13 11:07 | #115

Репутация: 408
Постов: 8023
из-за смены "ключей" и протоколов и не совместимы)
Да, конфликты с сервером решаются таким образом.
Я взял MPCP+C за основу, где за основу взят движок 1.5.2, но оба ключевых параметра,отвечающих за обработку файлов, изменены на подгрузку версии 1.5.1, таким образом производительность остается от 1.5.2, а версии модов и клиентов - 1.5.1.

12.06.13 12:47 | #116

Репутация: 130
Постов: 1103
Хочу поделиться невозможностью игры на сервере, он не работает. Кто знает почему? И когда он будет работать?
12.06.13 15:45 | #117

Репутация: 408
Постов: 8023
А где я объявлял, что он уже готов к работе? Или я где-то клиент выложил, который будет работать?) ноу.
я ещё вчера сказал, что сегодня скорее всего не будет

12.06.13 17:26 | #118

Репутация: 408
Постов: 8023
Ну, я постараюсь, чтобы завтра сервер заработал уже.
Если надо - посижу ночью над разработкой.

12.06.13 18:50 | #119

Репутация: 10
Постов: 345
надеюсь старая версия заработает на моем компе Х)
12.06.13 19:03 | #120

Репутация: 130
Постов: 1103
Цитата (animeshnik321)
надеюсь старая версия заработает на моем компе Х)


Фан Форум для LF'айтеров » Игровые Серверы » Minecraft » Сервак MC для LFF :3
Страница 6 из 10«1245678910»
Поиск: